易语言 电阻值计算工具 源码
标签搜索

易语言 电阻值计算工具 源码

admin
2021-12-20 / 1 评论 / 57 阅读 / 正在检测是否收录...
温馨提示:
本文最后更新于2021年12月20日,已超过286天没有更新,若内容或图片失效,请留言反馈。
.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 数值, 文本型
.局部变量 结果, 双精度小数型
.局部变量 次方数, 文本型
.局部变量 有效值, 文本型
.局部变量 文本长度, 整数型
.局部变量 i, 整数型
.局部变量 单位, 文本型

数值 = 编辑框1.内容
文本长度 = 文本_取长度 (数值)
次方数 = 取文本右边 (数值, 1)
有效值 = 取文本左边 (数值, 文本长度 - 1)
结果 = 到整数 (有效值) × 求次方 (10, 到整数 (次方数))
.计次循环首 (2, i)
    .如果真 (文本_取长度 (到文本 (到整数 (结果))) ≤ 3)
        跳出循环 ()
    .如果真结束
    结果 = 结果 ÷ 1000
.计次循环尾 ()
.如果真 (i = 1)
    单位 = “Ω”
.如果真结束
.如果真 (i = 2)
    单位 = “KΩ”
.如果真结束
.如果真 (i ≥ 3)
    单位 = “MΩ”
.如果真结束

编辑框2.内容 = 到文本 (结果) + 单位

3

评论 (1)

取消
  1. 头像
    admin 作者
    Windows 7 · Google Chrome

    表情

    回复